Recommended Posts

Hello,

we are experiencing few weird problems after this new versions, dunno if is related to server or client or both.

  1. Sometimes to the players only, few bots have EMPTY names, on the server I can see all names. Didn't happen today with 20.4, maybe was already fixed.
  2. Sometimes the top bar score/menu get stuck after the end of the map in the client, you still can listen the game and access the console, but nothing more responds, on the server you show as disconnected, without any error, not even a time out msg.
  3. Ambient Sound only works well at first spawn, then start to get crazy, and disappear most of times after first round, then we have a complete silence as background. Sometimes works again for another round, aside most of them are off.
  4. We have a random rain script in my mod, simply didn't happened a single time today for over 4 hours of gameplay, sounds very weird. But could be related with the lack of ambient sound, maybe COD4X is not executing the .gsc files from the maps as used to do? Could be the SAME cause here.
  5. Many things started to have weird behaviors, like fast_restart at the end of a match without any reason, shotguns not hiting anything, and several other small things that I need to re-check. I will test one by one to make sure what's going on, but if you could give me the changed list from 19.4 to all 20.X will help me a lot figure out what is causing all this

Again, you need to test this better before release and make the updates mandatory to everyone, you are killing the COD4 community like that, like the AlterIW.net clones do over and over releasing versions that cause so many errors to the players. You just released 5 versions in a week and STILL not working good.

Please make the auto-update option to the servers, then update first to some servers, test it with players in real matches for around a week, then when is fine release to all the public servers, when you are sure is 100%. 

Of course some bug might escape, but would be small and you can fix in the next update, but rushing 4 updates in a week trying to fix the errors caused by 20.0 still a bad move to COD4X, many players said they couldn't play / have fun during this week because of the bugs.

Of course, a public list of all changes to EACH version released should be added, it's for a looooong time a surprise what were released, in github nothing is updated for years, and we aside don't know the changes we also don't know the new features and how to use them, should have a better control to of these kind of updates for the health of this amazing project. 

It's very sad to have to stop playing in every major update, and having problems for a looong time until you get them fixed again. 

Well, it's just my suggestion to keep COD4X alive and also the players playing the game.

Cheers

 

Share this post


Link to post
Share on other sites

@FraggyLeave the client of the game and the server clean, remove all the trash that exceeds the assets!
delete jcod4x_00.iwd cod4x_ambfix.ff cod4x_patchv2.ff

To add assets there is a mod

Share this post


Link to post
Share on other sites
Quote

Again, you need to test this better before release and make the updates mandatory to everyone, you are killing the COD4 community like that, like the AlterIW.net clones do over and over releasing versions that cause so many errors to the players. You just released 5 versions in a week and STILL not working good.

 

Get off your high horse pal. People like you are killing the "community". What you've done here is listed problems of which you have no solutions to. So, with that in mind, understand that everyone volunteers here and maybe, just maybe you should volunteer some of your time to work out how best to move forward with these issues instead of making a list and expecting it to be done by other people.

 

/rant

Share this post


Link to post
Share on other sites
1 hour ago, Adam said:

 

 

Get off your high horse pal. People like you are killing the "community". What you've done here is listed problems of which you have no solutions to. So, with that in mind, understand that everyone volunteers here and maybe, just maybe you should volunteer some of your time to work out how best to move forward with these issues instead of making a list and expecting it to be done by other people.

 

/rant

 

 

Seams you can't even count Adam, take a look in my posts before saying that, I already spent several months debugging and suggesting solutions to COD4X for years now, just take look before talk shit on the forums. All these errors were caused by 20.X updates, and I already said that I will investigate them further in the post above. Wise up!

Share this post


Link to post
Share on other sites

I found this error on console, maybe is related to Ambient Sound bug:

Quote

^1Error: file for loaded zone 'cod4x_ambfix' not found

if "amb" have something related with ambient of course.

the error @gurinov reported there's nothing related with 20.X updates, but modified game/server files (hack?)

Share this post


Link to post
Share on other sites
1 hour ago, Hajas said:

I found this error on console, maybe is related to Ambient Sound bug:

if "amb" have something related with ambient of course.

the error @gurinov reported there's nothing related with 20.X updates, but modified game/server files (hack?)

This is just cosmetic. Ignore it.

Share this post


Link to post
Share on other sites
On 8/9/2021 at 6:05 AM, gurinov said:

Update 20.4, I get an error on most custom maps

shot0000.jpg

 

You reported it already in 19.x. I have never seen that error and don't know how to reproduce. With access to your client/server I could maybe debug it.

Share this post


Link to post
Share on other sites
On 8/9/2021 at 6:13 AM, gurinov said:

@FraggyLeave the client of the game and the server clean, remove all the trash that exceeds the assets!
delete jcod4x_00.iwd cod4x_ambfix.ff cod4x_patchv2.ff

To add assets there is a mod

cod4x_patchv2.ff isn't loaded when you load a mod. cod4x_ambfix.ff is gone from 20.5.

Share this post


Link to post
Share on other sites

Played with 20.5 tonight, no Ambient Sound after first round (no change). Very weird play rainy maps without rain sound. Hope this get fixed ASAP

I think the other issues gone.

A new issue is that the first time you run the game after update, starts without be able to hit esc (nothing happens), need to restart the game one more time to fix it. Happens to several of the players tonight, myself inclued.

Cheers

Share this post


Link to post
Share on other sites

Still very slow loading maps. The 'loading bar' is not the image that is in the MoD (mines orange) and seems out of place?

 

742348236_2021-08-1612_59_07-CallofDuty4X.thumb.png.5ba3d5e97d1f75174fbb7993fbf50ebd.png 

Share this post


Link to post
Share on other sites

@Fraggy is possible to fix the Ambient Sound until this Sunday? We will have some important guess at our server and will be pretty bad have rain without sound.

Thank you

Share this post


Link to post
Share on other sites
On 8/16/2021 at 5:57 AM, Hajas said:

Played with 20.5 tonight, no Ambient Sound after first round (no change). Very weird play rainy maps without rain sound. Hope this get fixed ASAP

Is that issue limited to your server/mod?

Or are all mods/servers affected by it.

Share this post


Link to post
Share on other sites
39 minutes ago, Fraggy said:

Is that issue limited to your server/mod?

Or are all mods/servers affected by it.

Happening to ANY COD4X with ANY mod

Share this post


Link to post
Share on other sites

Okay tested Obscurity mod and:

map mp_farm. -> Background sounds are there.

map mp_vukovar. -> Background sounds are there.

map mp_pripyat. -> Background sounds are there. One sound could be missing but I am not sure.

map mp_cargoship. -> Background sounds are there.

 

Looks like you need to become more specific than this.

Share this post


Link to post
Share on other sites
Posted (edited)

@FraggyDid you tested with Search & Destroy? Because like I said, works fine ONLY in the first round, then stop the sound until change map and repeat the same problem. Any map, any server, any mod.

here the END of the first round, ambient sound was working great then at the very end become silent.

https://youtu.be/Rxe3fBxBN4U?t=287

A game with 10 rounds, only the first one have ambient sound. 

All my 3 servers was working perfect for over 10 years, then with 20.X updates the Ambient Sound gone, can't be a problem with my mods.

Something is causing this in 20.X updates, all the versions since 20.0 have this bug, works perfect until 19.X versions.

PS: Another input, the sound become silent at the end of the FINAL KILLCAM, did you silent the Ambient Sound if change the speed of the game? Because the FINAL KILLCAM have a Slow Motion for few seconds, seams when the sound stop.

Edited by Hajas

Share this post


Link to post
Share on other sites
5 hours ago, Hajas said:

Search & Destroy?

I re-tested and it works just fine every time with or without mods. 

Share this post


Link to post
Share on other sites

So it's related with the FINAL KILLCAM slow motion I think, why is stopping the Ambient Sound when in slow motion?

Share this post


Link to post
Share on other sites
Posted (edited)

Nevermind, tested with Star Wars Gallactic Warfare mod, NO KILLCAM, no Ambient Sound after first round.

Is not related with the Slow Motion of the FINAL KILLCAM.

Tryed with MODwarfare, same bug!

Well, was working great since 2007, then after 20.X updates stop to work, we are wasting time here, the cause is in COD4X 20.X updates.

Something in the update is causing this.

Edited by Hajas

Share this post


Link to post
Share on other sites

Tried with modwarfare and also your own frontlines mod, it always works as it should. As noone can actually reproduce this "bug" don't expect it being fixed.

Share this post


Link to post
Share on other sites
6 minutes ago, leiizko said:

Tried with modwarfare and also your own frontlines mod, it always works as it should. As noone can actually reproduce this "bug" don't expect it being fixed.

please make a video of your test, because I have 8 PCs here with COD4, happening in ALL of them, ANY mod, ANY map.

probably you're not doing the right test I bet.

Make a video like the one that I sent above.

Share this post


Link to post
Share on other sites

I don't think there is a "wrong way" to play s&d game mode. Unless you do some weird stuff this bug does not happen.

Share this post


Link to post
Share on other sites
11 minutes ago, leiizko said:

I don't think there is a "wrong way" to play s&d game mode. Unless you do some weird stuff this bug does not happen.

I mean you are not playing accross the rounds like my video. 

Just check in our WhatsApp group, over 40 players with the SAME problem.

Was working fine until 20.X update. I sent you the video. The problem exist with evidences and several players with the exact same problem.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.