Sign in to follow this  
obteo

cod4x and B3 ban from B3 doesn't work

Recommended Posts

Hi guys maybe someone can help me, donno why but the B3 bans doesnt work on my server. I'm running the cod4x parser on B3 ban trough rcon works properly but not the one from B3 like !b name. Can anyone help me? cheers

Share this post


Link to post
Share on other sites
3 hours ago, obteo said:

Hi guys maybe someone can help me, donno why but the B3 bans doesnt work on my server. I'm running the cod4x parser on B3 ban trough rcon works properly but not the one from B3 like !b name. Can anyone help me? cheers

I suggest you stop b3 then delete your b3.log  then restart b3  test it by using any b3 command

then stop b3 again and post the new b3 log it made here.

Share this post


Link to post
Share on other sites

check your b3 and server log for the rcon command b3 sends to the server. i guess it's either wrong (parser problem?) or not sent at all.

Share this post


Link to post
Share on other sites

Hi thank you but I already checked that log, no error there is because I asked here. have u a working parser to try please? and btw, how to check if sends commands or not?

Share this post


Link to post
Share on other sites
Posted (edited)

I don't host any servers anymore so i am sorry but i can not send you a parser file.

You should see a rcon execution in your server log console_mp.log or qconsole.log when b3 sends a command.

 

edit: found a backup of our old servers on my pc :)

i've attached the two parser files.

 


in b3 log you will see the command execution like this (because you type it in chat):
 

181128 17:27:30 CONSOLE  '484:29 say;123hiddenguid456;12;Viking;!map mp_killhouse_2'

and in server log it appears like this:
 

Rcon from 123.hidden.ip.456:54653: map mp_killhouse_2

(the ip will be the ip of the machine the b3 tool is running at.

cod4x.py cod4x.pyc

Edited by Viking

Share this post


Link to post
Share on other sites
Posted (edited)

Thank you, I noticed after I don't know how many attempts that I can now ban through the command, and it takes a few seconds it is not immediate:

!pb @B3Number

other commands like

!b NAME

seems are not working, it says "no name match found.... ". Donno what changed i reopened the server now but a few months ago everything was working regularly...

Edited by obteo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this