Sign in to follow this  
={FMJ}=Smiley

Http Plugin

Recommended Posts

Hi All, 

I am wondering if anyone would share an already compiled http plugin with me. 
 

I am having trouble compiling it. Mainly because it’s the first time I tried ( and again and again) and don’t know wtf I am doing 😂 

thx in advance. 
Smiley. 

Share this post


Link to post
Share on other sites

you need to compile the server itself, then you can compile plugins against it :)

Share this post


Link to post
Share on other sites

Best I just leave it there then....no tutorials what I can see ....so many people using it and nothing to help :-( 

Share this post


Link to post
Share on other sites
6 hours ago, dpj said:

do you mean that one? i guess i could get it working for you, but it only works for linux as far as i remember

Yup, this is linux only.

Share this post


Link to post
Share on other sites

Yes i use linux always have done 🙂

 

And yes that's the one dpj. I did try but just failed miserably lol. I know with the plugin I can do some more things with the WebAdmin I use from NeHo. More for me to learn but failed at the first part lol.

Share this post


Link to post
Share on other sites
37 minutes ago, ={FMJ}=Smiley said:

Yes i use linux always have done 🙂

 

And yes that's the one dpj. I did try but just failed miserably lol. I know with the plugin I can do some more things with the WebAdmin I use from NeHo. More for me to learn but failed at the first part lol.

haven't tested if it's actually running yet, but i was able to compile it without issues.

first install the dlang compiler and dub build system (https://dlang.org/download.html); for ubuntu/debian:

sudo wget https://netcologne.dl.sourceforge.net/project/d-apt/files/d-apt.list -O /etc/apt/sources.list.d/d-apt.list
sudo apt-get update --allow-insecure-repositories
sudo apt-get -y --allow-unauthenticated install --reinstall d-apt-keyring
sudo apt-get update && sudo apt-get install dmd-compiler dub

you'll also need the phobos library

sudo apt install libphobos2-dev:i386

clone the plugin repository

git clone https://github.com/callofduty4x/cod4x_plugin_http.git

then compile the plugin with

dub --arch=x86 --build=release

now you should have "libcod4x_http_plugin.so"

 

  • Like 1

Share this post


Link to post
Share on other sites
40 minutes ago, dpj said:

haven't tested if it's actually running yet, but i was able to compile it without issues.

first install the dlang compiler and dub build system (https://dlang.org/download.html); for ubuntu/debian:


sudo wget https://netcologne.dl.sourceforge.net/project/d-apt/files/d-apt.list -O /etc/apt/sources.list.d/d-apt.list
sudo apt-get update --allow-insecure-repositories
sudo apt-get -y --allow-unauthenticated install --reinstall d-apt-keyring
sudo apt-get update && sudo apt-get install dmd-compiler dub

you'll also need the phobos library

sudo apt install libphobos2-dev:i386

clone the plugin repository

git clone https://github.com/callofduty4x/cod4x_plugin_http.git

then compile the plugin with

dub --arch=x86 --build=release

now you should have "libcod4x_http_plugin.so"

 

Perfect 🙂 Thank you very much. Now I just need to learn what to do with haha..Thanks mate.

Share this post


Link to post
Share on other sites

Is it because using with Windows? 

I have the plugin running no problem..But i cant find anywhere about what scripts to use, where they are supposed to go and how I can make it work 😞

Seen it in action on servers so I am missing out on this big time 😞 

Share this post


Link to post
Share on other sites
15 hours ago, ={FMJ}=Smiley said:

Is it because using with Windows? 

I have the plugin running no problem..But i cant find anywhere about what scripts to use, where they are supposed to go and how I can make it work 😞

Seen it in action on servers so I am missing out on this big time 😞 

Can you please give me the running plugin and i will give you the script to display fetched data in cod4

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this