Sign in to follow this  
darkie

Cod4x build 1004 crash

Recommended Posts

Posted (edited)

"version" is: "CoD4 X - linux-i386 build 1004 May 26 2020" default: "CoD4 X - linux-i386 build 1004 May 26 2020" info: "Game version"

 

This program has crashed with signal: Segmentation fault
The current Gameversion is: CoD4 X - linux-i386 type 'e' build 1004 May 26 2020
File is ./cod4x18_dedrun Hash is: 48dcc0cfbc5f594860c6040aa2ef84377cdfdd54ca0412497c08f7523d24f672
---------- Backtrace ----------
    9: ./cod4x18_dedrun(Sys_PrintBacktrace+0x31) [0x809d85b]
    8: ./cod4x18_dedrun(Sys_DumpCrash+0x92) [0x809d936]
    7: ./cod4x18_dedrun(Sys_SigHandler+0x24) [0x809d9ac]
    6: linux-gate.so.1(__kernel_sigreturn+0) [0xf7ed9b70]
    5: ./cod4x18_dedrun(Q_strncat+0x1b) [0x80ed7a5]
    4: ./cod4x18_dedrun(Com_PrintMessage+0x111) [0x8115286]
    3: ./cod4x18_dedrun(Plugin_Printf+0x2f) [0x80d6663]
    2: /root/.callofduty4/plugin.julia.tmp(+0x2fca) [0xdff92fca]
    1: /lib/i386-linux-gnu/libpthread.so.0(+0x63bd) [0xf7eab3bd]
    0: /lib/i386-linux-gnu/libc.so.6(clone+0x66) [0xf7b39e16]

-- Registers ---
edi 0x0
esi 0x0
ebp 0xdd2e2288
esp 0xdd2e2270
eax 0x0
ebx 0x0
ecx 0xffffffff
edx 0xffa59810
eip 0x80ed7a5
-------- Backtrace Completed --------
Received signal: Segmentation fault, exiting...
Server received signal: Segmentation fault
Shutting down server...
----- Server Shutdown -----
With the reason: 
Server received signal: Segmentation fault
Terminating server...

 

Edited by darkie

Share this post


Link to post
Share on other sites

seems to be an issue with the julia plugin

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, dpj said:

seems to be an issue with the julia plugin

I have beeen running the same version server with the julia plugin and have not had any crashes of my two servers

Edited by wkuzma
  • Like 1

Share this post


Link to post
Share on other sites

Well this is the first time my server ever crashed, not even in build 18/18.0.1. 
I'm keeping an eye if it happens again then will try out without julia.

Share this post


Link to post
Share on other sites
Posted (edited)

Only time mine crashed was map related. Assets error All servers have Julia running and have been up days with no errors. 
 

Although I cant use Julia commands because no Steam 🙂 


 

Edited by ={FMJ}=Smiley

Share this post


Link to post
Share on other sites

today my paintball server crashed can someone tell me what to look for  - here is the crash dump

This program has crashed with signal: Segmentation fault
The current Gameversion is: CoD4 X - linux-i386 type 'e' build 1004 May 26 2020
File is ./cod4x18_dedrun Hash is: 48dcc0cfbc5f594860c6040aa2ef84377cdfdd54ca0412497c08f7523d24f672
---------- Backtrace ----------
   13: ./cod4x18_dedrun(Sys_PrintBacktrace+0x31) [0x809d85b]
   12: ./cod4x18_dedrun(Sys_DumpCrash+0x92) [0x809d936]
   11: ./cod4x18_dedrun(Sys_SigHandler+0x24) [0x809d9ac]
   10: linux-gate.so.1(__kernel_sigreturn+0) [0xf7fd5b70]
    9: ./cod4x18_dedrun() [0x8189d84]
    8: ./cod4x18_dedrun() [0x818b5ed]
    7: ./cod4x18_dedrun() [0x818a4dc]
    6: ./cod4x18_dedrun() [0x81e6824]
    5: ./cod4x18_dedrun() [0x81aeffe]
    4: ./cod4x18_dedrun(SV_Frame+0xd9) [0x80f7209]
    3: ./cod4x18_dedrun(Com_Frame+0x79) [0x80e33ad]
    2: ./cod4x18_dedrun(Sys_Main+0x7b) [0x80a9790]
    1: ./cod4x18_dedrun(main+0xf9) [0x809d664]
    0: /lib/i386-linux-gnu/libc.so.6(__libc_start_main+0xf1) [0xf7b2ce91]

-- Registers ---
edi 0xcabff78
esi 0xcac00c0
ebp 0xffad2678
esp 0xffad2640
eax 0xc36be55b
ebx 0xc66e2f8
ecx 0x1c
edx 0x0
eip 0x8189d84
-------- Backtrace Completed --------
Received signal: Segmentation fault, exiting...
Server received signal: Segmentation fault
Shutting down server...
----- Server Shutdown -----

With the reason:
Server received signal: Segmentation fault
Terminating server...

 

 

Share this post


Link to post
Share on other sites

Did you try another map or was it one that's been OK in the past?

I am not the expert by far but this is what I had and when I then took out the map it was on when it crashed all OK. Just hit and miss with maps at the moment for me. The lighter the MoD the better. But every time I had a big map that did not work I got this segmentation fault. 

I am using a much smaller lighter mod now with less images blah blah and since then only a couple of problems. 

That's my experience anyway haha, its probably something completely else but thought I would share. 

 

Share this post


Link to post
Share on other sites

@wkuzma No clue as symbols are missing in the backtrace. Would have to open your server binary in IDA (interactive disassembled) and see how the symbols are named for this addresses. Possible it is still too hard to find out since it is within the disassembled code area - No C source code.

Share this post


Link to post
Share on other sites
3 hours ago, Fraggy said:

@wkuzma No clue as symbols are missing in the backtrace. Would have to open your server binary in IDA (interactive disassembled) and see how the symbols are named for this addresses. Possible it is still too hard to find out since it is within the disassembled code area - No C source code.

Thanks Fraggy - the server crashed once showing that error in qconsole.log - it was restarted and so far has been running for over 8 hours without a problem - it also cycled through all the maps in the rotation so maybe it was a one time problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this