Sign in to follow this  
darkie

How to downgrade server from 18.0 to 17.9

Recommended Posts

After a restart, my server automatically got upgraded to 18.0 day before yesterday.
Server seems to be crashing at random times. Unfortunately i didn't pay attention if it's crashing on any exact map/event.
Until 18.1 gets released i would like to revert back to 17.9 and keep it that way.

Q1.  So how do i downgrade the server (linux one)?
Q2.  Also have two other servers which i didn't restart and now i'm afraid of restarting the machines. Any way to stop it from checking update automatically and download the latest version?


Crash Log: https://pastebin.com/KhtBmh4x

 

Edited by darkie

Share this post


Link to post
Share on other sites

Since you are using my application you should have a symlink renamed in each directory cod4-port where the server got auto updated

The fle in main-server-files directory is the old version so you can use that file, simply rename the new file cod4x18_dedrun to cod4x18_dedrun-old and rename back the symlink to cod4x18_dedrun

Share this post


Link to post
Share on other sites
15 minutes ago, NeHo said:

Since you are using my application you should have a symlink renamed in each directory cod4-port where the server got auto updated

The fle in main-server-files directory is the old version so you can use that file, simply rename the new file cod4x18_dedrun to cod4x18_dedrun-old and rename back the symlink to cod4x18_dedrun

Oh yeah but unfortunately i have all external game servers, not the local ones :(

Share this post


Link to post
Share on other sites

You should have on all your external servers also the old file renamed, so just rename it back

  • Like 1

Share this post


Link to post
Share on other sites
13 minutes ago, NeHo said:

You should have on all your external servers also the old file renamed, so just rename it back

Thanks! Got it! :)

Share this post


Link to post
Share on other sites
12 hours ago, darkie said:

It seems like after 18.1 this trick isn't working any further.....

your right but 18.1 has been very stable on my servers

  • Like 1

Share this post


Link to post
Share on other sites

18.1 server is 17.9 with minimal additions to be compatible with the 18.x protocol plus newer bug fixes not included in 17.9.

That shouldn't be really unstable.

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this