Sign in to follow this  
Fraggy

Important new update will be out very soon

Recommended Posts

Because I have recently learned that this broken cvar system cause that the querylimit facility (Limiting amount of answers on getstatus, getinfo, TSourceEngineQuery) a new update will be released very very soon.

The effect of this fault are the followings: Your server can act as a potent reflector for so called Reflected-DDoS-attacks. Your server will appear in the packet logs of DDoS victim as the attacker.

In order to stop this all server based onto the "dev_newarch"-branch will receive very soon an autoupdate to version 17.8.

Servers still running the legacy master branch will not be touched at all. I am not aware the legacy version is affected by this at all.

If possible the dev_newarch branch servers getting restarted by the masterserver so they can grab their updates. However it is not clear yet if it works without jumping from 17.x to 18.x. It is required the serverfiles are owned by the user running the server so the autoupdate can complete.

In the next few minutes I will release updated server files on the forum. When you install them autoupdate will not kick-in.

 

 

Share this post


Link to post
Share on other sites

Update: Server-Download-Files on site have been updated.

Share this post


Link to post
Share on other sites

as long as the b3 works since that is the only thing that is used for fps and fov and take out the hack without that the hack do not let them play and the client is going to fuck

  • Haha 1

Share this post


Link to post
Share on other sites
Posted (edited)

Hi, where can I download the update?

I've found where they are, thanks, can you explain how to perform the update.

Edited by harold1979

Share this post


Link to post
Share on other sites
Posted (edited)

Hi, I made the update but now it does not recognize my steam account

 

I needed a file, thanks.

Edited by harold1979

Share this post


Link to post
Share on other sites
4 hours ago, harold1979 said:

Hi, I made the update but now it does not recognize my steam account

 

I needed a file, thanks.

Which file you need?

Share this post


Link to post
Share on other sites

Sorry do not explain me well, I need to add a file that's why it did not work, thank you very much for the update, greetings.

Share this post


Link to post
Share on other sites
6 hours ago, harold1979 said:

Sorry do not explain me well, I need to add a file that's why it did not work, thank you very much for the update, greetings.

you need steamclient.so and steam_api.so

(Considering you are using Linux)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this