Klauser

text HUD elements

Recommended Posts

Hello,

Im using promod 220 and added some scripts but rn im having problem with 2 of them im not sure what script is the problem, basically Im using finalkillcam and killcard and at the end the finalkillcam mix the text huds and change their positions or just dont show the text. It changes the strat text to the emblem position or it changes the "Promod LIVE 2.20" or "Custom Public" to another position or it just dont show any text... Is there a way to avoid this and keep the text huds in the correct position and "visible" in the finalkillcam? *That didnt happen in CoD4 1.7a.

Thanks.

Share this post


Link to post
Share on other sites

Code? For me, if the player was seeing a hud in game, they see it in finalkillcam.

Share this post


Link to post
Share on other sites

Code? Yes, for me it shows the hud things in the killcam but the bad thing is they change their position... Example* The "Custom Public" Hudtext is shown in the killcard emblem position or sometimes it just dont show the killcard emblem.

Share this post


Link to post
Share on other sites

I remember that that hapened to me if i put on too many hud elements. Check if you have duplicating names.

Share this post


Link to post
Share on other sites

if you exceed the maximum number of hudelements possible, any element exceeding the limit will not be visible.

i think hudelements need to have set the archived flag to be shown for spectators, might be the same for killcams.

 

Share this post


Link to post
Share on other sites
16 hours ago, tincxd said:

I remember that that hapened to me if i put on too many hud elements. Check if you have duplicating names.

No, they are ordered by numbers.

https://github.com/xtasix/RS-216/blob/master/duffman/_killcard.gsc

7 hours ago, dpj said:

if you exceed the maximum number of hudelements possible, any element exceeding the limit will not be visible.

i think hudelements need to have set the archived flag to be shown for spectators, might be the same for killcams.

 

Well. I think the max hud elements are 32 but I guess I dont have too many elements. The worst thing is only shaders with "setText" are not visible (or they change their position) in finalkillcam and they are visible in normal killcam. So I guess the problem is in the finalkillcam.

https://github.com/xtasix/RS-216/blob/master/maps/mp/gametypes/_finalkillcam.gsc

*I also tried the archived flag but it still doesnt work.

Share this post


Link to post
Share on other sites

*NOTE: It's also a problem of CoD4x just tested the mod in 1.7a for a whole map and all texts where always present in finalkillcam in their locations.

Share this post


Link to post
Share on other sites

I can't say how you can achieve that visibility in "replay" (aka "killcam") mode, but you definetely can and some of finalkillcam mode used that - in final killcam you can see overlay not exist in usual play.

Share this post


Link to post
Share on other sites

#1 should be "Promod ^1LIVE ^7V2.20" text (#5 of the 2nd capture)

#2 should be "^4Custom ^3Public" text (#4 of the 2nd capture)

#3 should be "Strat time:" text

 1.jpg.dab49b40c0ba9e34150543fce863b6e1.jpg

#4 should be "xtasix.me" text (the #1 of first capture)

#5 should be the emblem text" (#1 or #2 of first capture - most times the #5 is not visible)

2.jpg.5f65ea2bd48d315f2b6e6f924301d73f.jpg

and this last capture is exactly how it should look. (This one has been taken using cod4x 17a)

3.jpg.f06aeedab93d4b870966fb360a3e2481.jpg

Idk why in 1.8 it changes.

Edited by Klauser

Share this post


Link to post
Share on other sites

Does anyone know how to create a text newclienthudelem() using setvalue and not setText...

The problem of this is caused by setText and with setvalue it works good.

Share this post


Link to post
Share on other sites
10 hours ago, Klauser said:

Does anyone know how to create a text newclienthudelem() using setvalue and not setText...

The problem of this is caused by setText and with setvalue it works good.

create a hudelement, set a label set a value. done. what are you confused about? google for a bit, there are tons of examples out there.

Share this post


Link to post
Share on other sites

Yes, I know the label and setvalue things... I've been trying to reproduce the emblem with that but the server just crash when killcard is shown without error lines even if I use developer mode.

Share this post


Link to post
Share on other sites

In fact there's a overrall limit too, and is very close of all the already elements, I think you can only add one new at time and that's it, or will crash when you have more players in the server. If your server have less than 20 players you don't have to worry about it.

But make sure that you are creating the hud elements just once instead to each player when is possible, and don't forget to delete them after used, this will also avoid to reach the limits too.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now