Sign in to follow this  
Fraggy

New requirement for CoD4 X servers to get listed on masterserver

Recommended Posts

Happened with me as well, straight after restarted the dedicated server, all the servers was running at 100%. After I killed all the processes, and restarted the CoD4 servers, it went away, and now they are operating as normal. I have no idea why this gonna happens.

Share this post


Link to post
Share on other sites
On 12/24/2018 at 4:31 AM, AlexC said:

Happened with me as well, straight after restarted the dedicated server, all the servers was running at 100%. After I killed all the processes, and restarted the CoD4 servers, it went away, and now they are operating as normal. I have no idea why this gonna happens.

What OS do you use? I've tried rebooting the entire machine, restarting the server but its always at 100. (I've tried Debian 8&9 x32 x64)

Share this post


Link to post
Share on other sites
31 minutes ago, Klauser said:

What OS do you use? I've tried rebooting the entire machine, restarting the server but its always at 100. (I've tried Debian 8&9 x32 x64)

give it a try without steam_api.so

Share this post


Link to post
Share on other sites

Removed that file in 2 of 4 servers and it worked so I guess thats the problem (not sure had to restart them different times to get it) my question now is whats that file used for? how will it affect my servers? Thanks

Share this post


Link to post
Share on other sites
1 hour ago, Klauser said:

Removed that file in 2 of 4 servers and it worked so I guess thats the problem (not sure had to restart them different times to get it) my question now is whats that file used for? how will it affect my servers? Thanks

new is the topic for this thread 😛

send me a pm so we can figure out what's causing it and fix this.

Share this post


Link to post
Share on other sites

ahh Ye, should I open a new thread then? so everyone can get an answer if they get the same problem.

And I think the problem is that file steam_api.so

Share this post


Link to post
Share on other sites

what the fuck is that my server does not show in cod4x i put token in server.cfg but not working

  • Haha 1
  • Sad 1

Share this post


Link to post
Share on other sites

Hi I just started a cod4x server on centos 7 but would like to know ifCod4x 1.8 linux-i386 build 2055 May 2 2017 with a token will show on the cod4 server list.

For some reason it does not show up - the ip is 66.212.232.203 on port 28960 I used the same token as my other servers which do show on the list however they are on a different IP .69.244.124.115 and use Cod4x-win_mingw-x86 build 916  Sep 15 2018. The name of the server in question is IOG COD4X Bolt Sniper Is there something I have to do to correct this problem? I used the linux package from this web site

Share this post


Link to post
Share on other sites
11 minutes ago, wkuzma said:

Hi I just started a cod4x server on centos 7 but would like to know ifCod4x 1.8 linux-i386 build 2055 May 2 2017 with a token will show on the cod4 server list.

 

On 8/26/2018 at 11:39 AM, Fraggy said:

This requires a new version (17.6) of CoD4 X server you can download from the front-page.

 

Share this post


Link to post
Share on other sites
On 8/26/2018 at 11:39 AM, Fraggy said:

Because of recent spamming events on the masterserver we had to implement some sophisticated way to stop people from spamming their servers when they have available a large number of different IP-addresses.

Gameservers need to prove now on registration at masterserver to have set a valid token in cvar sv_authtoken. If they can not prove to have this token they get rejected on masterserver. This requires a new version (17.6) of CoD4 X server you can download from the front-page. However the new version of CoD4 X server could still be less stable than the prior version as the core design is really new.

Do I need a token? Well if your server is still listed on http://cod4master.cod4x.me/ you don't need a token and don't need new serverversion yet unless you change your IP address.

 

Where do I get this token? You get it on: https://cod4master.cod4x.me/ and click the link "Get a Token". Here you need an unlimited and clean Steam account.

dVXl8aL.png

 

What can I do with that token? Well you can either put into your server's commandline:

+set sv_authtoken "mytokenhere"

Or you edit your server.cfg file and add:

set sv_authtoken "mytokenhere"

Of course you need the new server-version to use tokens.

 

Can I use this token on multiple servers?

Yes this token is supposed to be used on all gameservers you own. Creating a new token will disable your old onw.

 

The requirement to obtain a token can be changed if we have to believe this is not sufficient anymore and our service gets still frequently abused.

hello all, guys happy new year, whish you all the best

thanks for this info Fraggy and dpj

so i must buy CoD4 key by Steam license

and add this command

on start.bat       =>    +set sv_authtoken "mytokenhere"

or in server.cfg  =>     set sv_authtoken "mytokenhere"

and mytokenhere = steam ID?

 

thanks for answear

 

 

Share this post


Link to post
Share on other sites
7 hours ago, {cool.G} ingre said:

so i must buy CoD4 key by Steam license

No, you only need an unlimited steam account

7 hours ago, {cool.G} ingre said:

and mytokenhere = steam ID?

No, read the post you quoted

  • Like 1

Share this post


Link to post
Share on other sites

I have an unlimited account, almost 4 years, level 41, etc...but for a ban, I can't have a token.
Is it possible that I will be allowed to have one? 🤔 At most I will have 2 servers (and they won't be 24/7, for now).

Share this post


Link to post
Share on other sites
On 1/29/2019 at 4:18 PM, Soy R.A. said:

I have an unlimited account, almost 4 years, level 41, etc...but for a ban, I can't have a token.
Is it possible that I will be allowed to have one? 🤔 At most I will have 2 servers (and they won't be 24/7, for now).

maybe you created new accaunt steam?

 

  • Confused 1

Share this post


Link to post
Share on other sites
On 1/14/2019 at 5:19 AM, dpj said:

 

 

hmm did not transfer the quoted message

so here it is This requires a new version (17.6) of CoD4 X server you can download from the front-page.

but thanks DPJ I should have known since it was build 2055  but sometimes I forget things like that

installing the version from the front-page cured it.

Edited by wkuzma

Share this post


Link to post
Share on other sites

Hi, run server normal and i setup token in cfg and in command line... using CoD4 X 1.8 linux-i386 build 2055 May  2 2017. But don't work for me..
i got messege :

Steam: Server connected successfully
GameServer is not VAC Secure!
GameServer SteamID: [A:1:730319874]
Resolving cod4master.activision.com
cod4master.activision.com resolved to 185.34.104.231:20810
Hitch warning: 2146 msec frame time
Invalid or empty response from masterserver
Resolving cod4master.activision.com
cod4master.activision.com resolved to 185.34.104.231:20800

Invalid or empty response from masterserver
Invalid or empty response from masterserver
Invalid or empty response from masterserver

And i don't have limited steam..because i have many of game's on account.

Edited by FloKy.sLo

Share this post


Link to post
Share on other sites

Hi i think you are using too old server version so first update your server files

Share this post


Link to post
Share on other sites
8 hours ago, FloKy.sLo said:

Hi, run server normal and i setup token in cfg and in command line... using CoD4 X 1.8 linux-i386 build 2055 May  2 2017. But don't work for me..
i got messege :

Steam: Server connected successfully
GameServer is not VAC Secure!
GameServer SteamID: [A:1:730319874]
Resolving cod4master.activision.com
cod4master.activision.com resolved to 185.34.104.231:20810
Hitch warning: 2146 msec frame time
Invalid or empty response from masterserver
Resolving cod4master.activision.com
cod4master.activision.com resolved to 185.34.104.231:20800

Invalid or empty response from masterserver
Invalid or empty response from masterserver
Invalid or empty response from masterserver

And i don't have limited steam..because i have many of game's on account.

Update your server to the one from the front page: https://cod4x.me

 

Share this post


Link to post
Share on other sites
7 hours ago, K4r3l01 said:

Hi i think you are using too old server version so first update your server files

I use from LGSM can u tell me how to update it?. 

Share this post


Link to post
Share on other sites
35 minutes ago, FloKy.sLo said:

How can i update? only download Linux server files and replace it ? then  run server?

Somewhere amongst the server files should be some dedrun files, you want to replace those with the ones from this website. 

Been about 2 years since I last used lgsm, but it should be fine once you make those new server files executable. 

 

Share this post


Link to post
Share on other sites
2 minutes ago, Koaja said:

Somewhere amongst the server files should be some dedrun files, you want to replace those with the ones from this website. 

Been about 2 years since I last used lgsm, but it should be fine once you make those new server files executable. 

 

I have downloaded files and copy to serverfiles dir. now it's all crached :)

Share this post


Link to post
Share on other sites
3 minutes ago, FloKy.sLo said:

I have downloaded files and copy to serverfiles dir. now it's all crached :)

Create a new topic with the crash log @ me in it if you want and I will have a look. 

Share this post


Link to post
Share on other sites
Just now, Koaja said:

Create a new topic with the crash log @ me in it if you want and I will have a look. 

I will install again the server now and try again :)

Share this post


Link to post
Share on other sites
23 minutes ago, FloKy.sLo said:

I will install again the server now and try again :)

i install fresh server via LGSM then i download linux files from cod4x.me and replace it with olders. now when i run command ./cod4server start i got error

cod4server@vmi231958:~$ ./cod4server start
[ INFO ] Starting cod4server: Check IP: 178.238.238.254
no server running on /tmp/tmux-1000/default
[ FAIL ] Starting cod4server: Unable to start LinuxGSM
cod4server@vmi231958:~$

script log is:
Feb 13 15:05:50.464 cod4server: START: FATAL: Unable to start LinuxGSM
Feb 13 15:05:50.969 cod4server: START: FATAL: command_start.sh exiting with code: 1
Feb 13 15:06:48.128 cod4server: CHECK: INFO: IP automatically set as: 178.238.238.254
Feb 13 15:06:48.498 cod4server: START: INFO: Rotating log files


 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this